Issues loading redemption links

Incident Report for &Open

Resolved

This incident has been resolved
Posted Dec 16, 2025 - 17:57 GMT

Monitoring

A fix has been implemented and systems are working correctly.
The team is working now to monitor the fix and also apply all permanent messures to prevent the issue from happening again.
Posted Dec 16, 2025 - 16:32 GMT

Identified

We have identified an issue loading redemption links.
The team has quickly found the problem and are working to get a fix in the next few minutes.
Posted Dec 16, 2025 - 16:25 GMT
This incident affected: &Open Platform.